Missing administration controls...

Aug 19, 2009 at 10:18 AM

Hi I just added and configure the ADRP.

I can login into the blogengine with my domain account. I have edited the RoleGroupConfig config file to match my domain groups.

But when I'm logged there is no links in the administration tabs abd the controle panel is not acessible, i'm always redirected to the change your password....

Is there a trick to activate the control panel access???

 

 

Aug 19, 2009 at 3:50 PM

Psylion,

There are several places you will want to check to make sure you role is assigned to the page you are trying to access.

/Web.sitemap in the root of the website assigns roles to pages in the admin section.

/admin/Pages/Web.config assigns authorization for roles on the pages in the admin section.

So those are the two places to check to make sure the authenticated user's role is authorized for the correct page.

You should make sure that your user is in fact a member of the AD group that is assigned to the role that has access.

There is also a node in the root Web.config file that assigns the admin role's name. Make sure this matches the name of the admin role you are using.

The node looks like this, it is in the appSettings section:


<!-- The name of the role with administrator permissions -->
        <add key="BlogEngine.AdminRole" value="Administrators"/>       

Hope this helps!

Rafe

Sep 28, 2009 at 12:10 PM

Hi Psylion, 

I have same problem with you, do you found the solution ?

Rafekemmis please advice.

Thanks,

Bag

Oct 10, 2009 at 3:24 PM

Hi bagnin, were you able to solve your problem? If not, would suggest checking reviewing the items in my previous post if you haven't already.

 

best,

Rafe